Degraded Performance
Incident Report for ValidSign
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 10:10 CEST
Update
First of all, we would like to apologize for the reduced performance you may have experienced using our services over the past week. We understand that this may have been frustrating and may have impacted your work processes.

We want to let you know that we have identified the issues and have done everything possible to resolve them as quickly as possible. Our team of technical experts has worked hard, together with our hosting provider, to identify the cause of the problems and make the necessary adjustments.

We are pleased to report that the application's performance is satisfactory today and that our services are functioning optimally again. Of course, we will continue to monitor this closely in the coming days and weeks and an evaluation of the situation will be made.

We want to thank you for your patience and understanding during this period, and we want to assure you that we will continue to strive to provide high-quality services to our customers.

If you have any questions or need support, please feel free to contact us.
We are always ready to help you.
Posted Apr 05, 2023 - 10:30 CEST
Update
We have implemented additional changes and are evaluating and testing these changes. We will be closely monitoring these changes and the effect during the night and early morning. We'll keep you updated through this page.
Posted Apr 04, 2023 - 23:49 CEST
Update
We still experience performance issues on the platform but see slight improvement on the platform itself, which cannot directly be seen through raw performance at this moment of time. We are still making small adjustment that will help performance. Currently, we are monitoring these adjustments and further changes will be made to improve the performance of the application.
Posted Apr 04, 2023 - 14:17 CEST
Update
We would like to inform you that we have been working hard over the past few days and nights to resolve performance issues. The adjustments that were made over the weekend, combined with those from last night, appear to be having an effect. However, the performance of the application is still not at the desired level. Currently, we are monitoring these adjustments and further changes will be made to improve the performance of the application.
Posted Apr 04, 2023 - 10:16 CEST
Monitoring
We have implemented the scheduled changes during our maintenance period and are evaluating and testing the changes. We will be closely monitoring these changes and the effect during the night and early morning. We will keep you updated through this page.
Posted Apr 03, 2023 - 22:54 CEST
Update
We are continuing to work on the issues of the reduced performance on our platform. We are ready to make some new changes that will be implemented later tonight. We will experience downtime later tonight to configure the latest changes. Maintenance is announced separately. The application is operational, but it may take longer for pages and/or documents to load. We are working hard to address the cause of this delay. We will keep you updated through this page.
Posted Apr 03, 2023 - 17:55 CEST
Update
We are continuing to work on the issues of the reduced performance on our platform. We are preparing some new changes that will be implemented later this afternoon/tonight. We will experience downtime later tonight to configure the latest changes. Maintenance will be announced separately. The application is operational, but it may take longer for pages and/or documents to load. We are working hard to address the cause of this delay. We will keep you updated through this page.
Posted Apr 03, 2023 - 14:53 CEST
Update
We are continuing to work on the issues of the reduced performance on our platform. We are preparing some new changes that will be implemented later this afternoon. The application is operational, but it may take longer for pages and/or documents to load. We are working hard to address the cause of this delay. We will keep you updated through this page.
Posted Apr 03, 2023 - 12:31 CEST
Update
Unfortunately, we are experiencing performance-related issues on the platform again today, despite the adjustments made last weekend. We will continue to make adjustments to the configuration throughout the day, together with our hosting provider, to ensure that the root cause is addressed. We apologize for the inconvenience. We will keep you informed of developments through this notification.
Posted Apr 03, 2023 - 09:46 CEST
Update
We have implemented some changes to the platform and will closely monitor the effect during the early morning. The application is operational at the moment. We are working hard to address the root cause of the issue. We will keep you updated through this page.
Posted Apr 03, 2023 - 03:09 CEST
Update
We are continuing to work on the issues of the reduced performance on our platform during the weekend. We've implemented some changes and are monitoring these changes continuously throughout the weekend. The application is operational at the moment. We are working hard to address the root cause of the issue. We will keep you updated through this page.
Posted Apr 01, 2023 - 21:37 CEST
Update
We are continuing to work on the issues of the reduced performance on our platform this weekend. We've involved more resources to further investigate these issues and will implement different measures this weekend. The application is operational at the moment. We are working hard to address the root cause of the issue. We will keep you updated through this page.
Posted Apr 01, 2023 - 00:03 CEST
Update
We are still investigating the issues of the reduced performance on our platform. We've involved more resources from our different parties to further investigate these issues. The application is operational, but it may take longer for pages and/or documents to load. We are working hard to address the cause of this delay. We will keep you updated through this page.
Posted Mar 31, 2023 - 15:17 CEST
Update
We are continuing to investigate the issues of the reduced performance on our platform. The application is operational, but it may take longer for pages and/or documents to load. We are working hard to address the cause of this delay. We will keep you updated through this page.
Posted Mar 31, 2023 - 12:15 CEST
Identified
At the moment, we are experiencing reduced performance on our platform. The application is operational, but it may take longer for pages and/or documents to load. We are working hard to address the cause of this delay. We will keep you updated through this page.
Posted Mar 31, 2023 - 11:07 CEST
This incident affected: ValidSign Production (ValidSign Frontend (my.validsign.eu), ValidSign API (my.validsign.eu)).